Back to overview
Downtime

Search functionality is down due to 3rd party SSL errors

Mar 25, 2026 at 10:30am UTC
Affected services
Search

Resolved
Mar 25, 2026 at 1:49pm UTC

Search functionality restored.

The SSL connection issues with our search provider (Meilisearch Cloud, Frankfurt region) have been fixed.
Incident Summary

  • Started: March 25, 2026 (~11:24 CET)
  • Affected: Search functionality in Kavitro
  • Root cause: Unexpected SSL errors on Meilisearch Cloud’s Frankfurt cluster
  • Resolution: Fixed by Meilisearch team (official incident: https://status.meilisearch.com/en/incident/857216)

Search is now fully operational again.

What we’ve done
We have added a dedicated Search monitor to our status page. Going forward, any similar issues will be automatically detected and shown with its own uptime monitoring.

We apologize for the inconvenience this caused and thank you for your patience.

Created
Mar 25, 2026 at 10:30am UTC

Our search provider, Meilisearch Cloud (Frankfurt region), is currently experiencing unexpected SSL errors.

This is causing problems with search within Kavitro.

We are monitoring the situation closely.

Official incident report from Meilisearch: https://status.meilisearch.com/en/incident/857216

Expected resolution: We will update this announcement as soon as the issue is resolved on their side.